System Requirements

Important Note:  The contents of this document applies ONLY to version 5.x.x of Simple:Press.  It likely does NOT apply to version 6.x.x (our latest version).

To run the latest version of Simple:Press the following system requirements need to be met:

Simple:Press requires WordPress . If you are running a lower version of WordPress you will need to have an older version of Simple:Press.

WordPress

WordPress version or newer.
You can check your WordPress version in your site ‘dashboard’. It is displayed in the footer on the right hand side.

PHP

PHP version or newer including the GD graphics library.
If you do not know it you can check your php version with your host.

MySQL

MySQL version or newer.
You can check your MySQL version with your host or with a tool such as phpMyAdmin – usually available from your hosting control panel.

jQuery JavaScript Library

Simple:Press requires and is only supported on the version of jQuery and the jQuery UI components supplied with your version of WordPress. Sadly many themes and plugins insist on loading their own, out-dated and often incompatible versions instead of using the WordPress API. Worse, some load jQuery from the Google CDN. In many cases, such sources are not compatible with Simple:Press.

caching

Using Caching Plugins

Simple:Press creates dynamic WordPress pages and cannot be cached in the usual manner. There are built in caching and compression features within Simple:Press.  If running a caching plugin the WordPress page the forum is displayed on needs to be excluded for all types of caching in use.

Posted in